RFE: Disable default OpsGenie message at the start of an incoming call


#1

When you configure an incoming call integration and put in place the auto-responder, the first thing you hear when dialing in is still the default message of ‘please hold while we try to contact your engineer’.

Our integration being equipped with the auto-responder and set to only use voicemail makes the wording rather contradictory. The custom greeting message we configured for the auto-responder obviously is read to the incoming caller just after that but being able to customize or disable that first sentence … or at least it not saying ‘we’re trying to call someone for you right now’ would be an improvement.

Cheers,
Pedro


#2

Hi Pedro,

Excuse us for spotting your message so late! I think what you are experiencing is the default welcome message of the integration. Let me elaborate a bit: whenever a call comes in, Opsgenie plays the welcome message. If there is an auto-attendant configured, that sound file or text is the next one. Once all the options are exhausted, Opsgenie plays the sound/reads the text in the “leave a message” section.

I think the weird behavior you are experiencing is caused by the fact, that directly forwarding the caller to the voicemail is a bit of a hacky solution currently. You are setting the “How many users should be tried:” to 0, right?

In that case, the “welcome message” doesn’t make a lot of sense, since the “leave a message” field could capture all necessary information. I think the expected behavior could be to disable the welcome message automatically. However, this is not the case. Here is a workaround for now:

You can try capturing an empty welcome message:

The dash is needed (or a dot, etc.), otherwise, the validation won’t let you save the integration. This will result in a deleted welcome message and only the text in the “leave a message” field will be read.

Do you think this could work for you?


#3

Thanks for that. Seeing the auto-attendant was above the welcome message I mentally skipped it completely.

Adjusting it as mentioned above fixed it.