OpsGenie Android no longer adjusting volume on Do Not Disturb


In the last couple weeks I’ve noticed an issue where OpsGenie will no longer override my phone’s “Do Not Disturb” setting to alert. It used to work just fine! Here’s my setup:

  • Android 8.0.0
  • OnePlus 3T
  • Do Not Disturb Access is enabled for OpsGenie
  • OpsGenie setting “Always play OpsGenie notification sounds at maximum volume” is enabled
  • OpsGenie setting “Vibrate” is enabled

With my phone in normal mode and the screen locked, I sent myself a test alert, and the notification came through just fine with sound.

With my phone on Do Not Disturb mode and the screen locked, I sent myself another test alert, and the notification came silently, with no sound, and the screen did not turn on.

I’ve missed a couple of real alerts because of this recently, so I can no longer have my phone on DnD mode when I’m on call. Is there something I’m missing, or any kind of fix?


Hi Alex, thanks for reaching out. We are aware of the problem and working on a fix right now. We will send this ASAP. We apologize for the inconvenience that this bug is causing you.


Hi Alex, we solved the issue last week. You can take a look at this doc for further info: https://docs.opsgenie.com/docs/android-app-changing-notification-sound-for-different-alert-actions

Let us know from here or chat on opsgenie.com if you have a question.


Same problem here (OnePlus 5); tried several combination of notification settings (plus uninstall/reinstall, clear storage, …), and I have done all the steps listed on https://docs.opsgenie.com/docs/android-app-changing-notification-sound-for-different-alert-actions.
Seems that OxygenOS on Oneplus phones block all notification in Do Not Disturb, due to hardware switch override.
Here is a thread talking about this problem : https://forums.oneplus.com/threads/i-cant-override-notifications-in-do-not-disturb.634739/#post-17238496
It seems that the provided workaround (on support.google.com) does not apply to OxygenOS and I haven’t tried the tasker/macrodroid workaround yet.