Notification policies do not affect integration i.e. Slack


#1

Hi,

We got integration which send out information about alert into Slack. We have implemented notification policy to suppress specific notifications and it works as designed by not alerting on call person however notifications to Slack seems to be unaffected by this and we are getting “spammed” with already closed alerts.

What would be the correct approach on getting this solved ?


#2

Hi @RafPe,

Slack is categorized as an integration and not as a notification channel inside Opsgenie, that is why the Policies are not applied. It’s an outgoing integration request, hence you’ll need to fine-tune your integration settings.

Good news is, suppress (basically filter out certain alerts) should be fairly straightforward.

  • Head over to your Slack integration in OpsGenie (whichever channel you are trying to clean up)
  • Find the Alert Filter section, which - by default - looks like this:

This section is the one which defined when the integration is triggered. Whichever alert is matching the filter, will post a message to your slack channel when the checked actions are executed.

  • Filter out the alert you don’t want to have on your channel. As an example, if your notification policy says “IF alert contains tag1 OR tag2 THEN suppress”, your filter in the integration would look like this:

In short: the alert filter in your integration settings enables you to send only a subset of the alerts. You may exclude the alerts you don’t want to see on your channel there.


#3

Thanks Daniel - I think that is what I was looking for :slight_smile: