Installing and configuring OpsGenie Logstash plugin in Logstash 5.4


#1

I am trying to install the OpsGenie output plugin (v2.0.5) in Logstash (v5.4.2).

According to the OpsGenie instructions, one has to run for some of the training:

bin/plugin install logstash-output-opsgenie
which in Logstash 5.4 should be:

bin/logstash-plugin install logstash-output-opsgenie
Running this you get:

Looking if package named: logstash-output-opsgenie exists at https://artifacts.elastic.co/downloads/logstash-plugins/logstash-output-opsgenie/logstash-output-opsgenie-5.4.2.zip
(but there is no such artifact: logstash-output-opsgenie-5.4.2.zip)

Even trying to force the version:

$ DEBUG=1 bin/logstash-plugin install --version 2.0.5 logstash-output-opsgenie
you still get:

DEBUG: exec /usr/share/logstash/vendor/jruby/bin/jruby /usr/share/logstash/lib/pluginmanager/main.rb install --version 2.0.5 logstash-output-opsgenie
Looking if package named: logstash-output-opsgenie exists at https://artifacts.elastic.co/downloads/logstash-plugins/logstash-output-opsgenie/logstash-output-opsgenie-5.4.2.zip
Network error, skipping Elastic pack, exception: Connection refused - Connection refused
How can I install this Logstash output plugin?