Android Oreo 8.1 Notifications Always Playing at Full Volume


I just upgraded to Android Oreo 8.1 and all of my notifications go to full volume no matter what I do. With other versions I was able to control the volume but not now. If I have my phone on vibrate once an OpsGenie alert comes in my volume goes to max. Please help as this is unusable for me.


Hey Robert,

Not sure how that is possible with our current version of the Android app. Previously (pre 8.0), there was a button in the application which enabled you to override the volume levels and push the notification out on the maximum volume, but that is not possible on Android 8.1 anymore as the whole notification management moved to the OS level into the Settings menu and is not dependant on OpsGenie anymore.

The only option we have on the app-side now is to let the notification through your Priority Only mode, but that will play the selected sound on the current volume level and it should not raise it.

Can you check the Settings >> Apps and notifications >> Opsgenie menu and share which version of the OpsGenie app you are currently using?


Hi @robert.endicott,

Can you try deleting the application data in Settings >> Apps and notifications >> OpsGenie >> Storage? I think we’ve managed to reproduce this error. This would be a quick fix. Don’t forget to log back in after this!


I went into the OpsGenie Storage like you said and deleted the data and I am still having the issue. I am on version 2.4.0.


@robert.endicott, can you head over to the Play Store and upgrade to the latest version? We’ve pushed out a release today, which brings back the old “Always play notifications on maximum volume option” under the Notifications Settings >> Sounds menu.

You can disable that option - I believe this will fix the issue. It appears this - even though we’ve removed it, thinking it’s not available in the new OS anymore - stuck around after app update.

Can you send a message back here, if this was successful? And of course - we are sorry for the inconvenience this might have caused!


@Daniel I upgraded to the latest Android version and now have the “Always play notifications on maximum volume option” which does resolve my issue. Thank you for addressing this issue, it is a huge help.


Great to hear that Robert, thanks for sharing the results - sorry that we’ve missed this before! Do let us know if anything else comes up!