Android 8.1 Notifications always use default ringtone


#1

Hi,
After upgrading my phone to Android 8.1 all OpsGenie notifications just use the same default tone set in my phone settings (which is just a little beep “chime” or something that won’t wake you up at night).
However, via AndroidSettings -> Apps & Notifications -> OpsGenie -> app-notifications -> Default-category, I can set another tone which then get’s used for all OpsGenie notifications. Also not very satisfying.

I read there are similar problems for the Android SMS/Messanger app and for example the Twitter app cause of the newly introduced notification channels in 8.1.
See Pixel Default Notifcation Sound overriding App Nofication Sound

The App-Notifications settings for Twitter show various types of notifications (categories) to set different tones and other settings (like do not disturb, vibrate and so on).

I already tried wiping the app-cache, re-installed the app but without success.

Google Pixel XL, Android 8.1.0, Security Update 5. Jan 2018
OpsGenie 2.3.7


#2

Hi @mpre,

Indeed, it’s a new Android feature and now our old way of setting ringtones for different notification rules cannot be used in that version. Good news is, our Mobile team is working on this problem as we speak and we hope to release a new app version soon. We will be using those notification categories also!

Thanks for the detailed post! I’ll follow-up here, once it’s out there!


#3

Hi @Daniel,
thx for the update. Looking forward for the next release :wink:


#4

Hi @mpre,

Sorry for the delayed response - we’ve released the new version of the mobile app last week, which enables you to use the new notification settings for the Oreo (and higher) versions on Android. Let me copy the piece of documentation we have now:

"If the Android version that you are using is Android Oreo or higher, you can modify your
Notification Settings (Sounds, Vibration , Do Not Disturb etc…) from App Notification Settings.
You can follow the steps below for editing your Notification Settings.

Settings -> Apps & notifications -> App info -> Opsgenie -> App Notifications
or
You can directly long press on Opsgenie appicon from Home Screen then click App info -> App Notifications
And then by selecting related notification category (that are under categories section), you can modify your notification settings.

Important Note : In order to view these notification categories, at least one notification should be received for each of the related actions.

In other words when you first install the app or update your Android to Oreo or higher, your notification categories will be empty. But when a
push notification for the related action is received once , it will appear under your Categories."

Let me know if you have any questions, would be happy to assist!


#5

Hi Folks, I found solution to get rid from those default notification sound. You can download any sound recorder app and record small audio of equal or less than 1 second duration. After that you can set your notification tone with that recorded audio. In result you will get notification but not default annoying notification sound. I did that and it works fine as expected to me.